ورود به حساب ثبت نام جدید فراموشی کلمه عبور
برای ورود به حساب کاربری خود، نام کاربری و کلمه عبورتان را در زیر وارد کرده و روی «ورود به سایت» کلیک کنید.





اگر فرم ثبت نام برای شما نمایش داده نمی‌شود، اینجا را کلیک کنید.









اگر فرم بازیابی کلمه عبور برای شما نمایش داده نمی‌شود، اینجا را کلیک کنید.





تبلیغات تبلیغات
صفحه 1 از 2 12 آخرین
نمایش نتایج: از 1 به 10 از 11
  1. #1
    تاریخ عضویت
    2021/01/30
    نوشته ها
    27
    امتیازها
    188
    سطح
    3
    3
    کاربر جدید

    Angry سه مشکل با wsl

    سلام سه باره. خب بی مقدمه سراغ مشکل میرویم. مشکلات من:
    1. شبکه در wsl | الان ببینید کارت شبکه من درست کار میکنه ولی وقتی میرم تو wsl دستور iwconfig رو میزنم:
    sit0 no wireless extensions.


    bond0 no wireless extensions.


    lo no wireless extensions.


    eth0 no wireless extensions.


    dummy0 no wireless extensions.
    آخه چرا؟ من واقعا نیاز دارم چون برای کار های شبکه میخواستم مثلا مانیتور کارت شبکه. ولی نشد. و اینم بگم که این مشکل تو تاپیک قبل https://forums.sakhtafzarmag.com/thr...%D9%86-hyper-v یعنی subnet mask شبکه درست شد ولی هنوز مشکل no wireless extension هست.
    ولی فکر کنم مشکل از خود wsl باشه چون:
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 192.168.3.16 netmask 255.255.255.0 broadcast 192.168.3.255
    ether 005d:1e:d1:f7 txqueuelen 1000 (Ethernet)
    RX packets 592 bytes 61507 (60.0 KiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 170 bytes 29540 (28.8 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 coll***ons 0
    مثل کابل اترنت شناسایی میشه! لطفا اگه کسی بلده بگه چطوری اینو از این حالت در بیارم.
    2. من هم wsl رو میخوام و هم ld player. من wsl 2 دارم که یه feature جدید میخواد که اون قابلیته مجازی سازی رو غیر فعال میکنه! چیکار کنم؟ تنظیماتی نیس که هر دو رو بشه باز کرد؟
    3. هر وقت ip wsl خراب میشه دو دستور
    کد:
    sudo ip addr flush dev eth0
    sudo dhclient eth0
    اجرا میکنم. الان جدیدا هم wsl به اینترنت وصل نمیشه و هم وقتی دستور دوم رو اجرا میکنم میزنه:
    PING 192.168.3.1 (192.168.3.1) 56(84) bytes of data.


    --- 192.168.3.1 ping statistics ---
    1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms
    حل شد. کارت شبکه از network bridge جدا شده بود.
    ----------------------------------
    لطفا یکی راهنمایی کنه ممنون.
    ویرایش توسط mammad24amin : 2021/02/21 در ساعت 16:46 دلیل: بعضی مشکلات حل شد
  2. #2
    تاریخ عضویت
    2014/09/29
    محل سکونت
    IoT Devices
    نوشته ها
    2,971
    امتیازها
    159,550
    سطح
    100
    9,328
    متخصص شبکه و الکترونیک
    سلام. کدوم توزیع لینوکس رو استفاده میکنید ؟

  3. #3
    تاریخ عضویت
    2021/01/30
    نوشته ها
    27
    امتیازها
    188
    سطح
    3
    3
    کاربر جدید
    نقل قول نوشته اصلی توسط ErfanDL نمایش پست ها
    سلام. کدوم توزیع لینوکس رو استفاده میکنید ؟
    سلام کالی لینوکس رو نصب کردم.
    بقیه توزیع ها حجمشون بیشتر بود.
    ناگفته نمونه برای کار های شبکه خواستم.
    و اینم بگم من از network bridge استفاده میکنم. کارت wsl رو با کارت ویندوز میزارم تو network bridge
  4. #4
    تاریخ عضویت
    2021/01/30
    نوشته ها
    27
    امتیازها
    188
    سطح
    3
    3
    کاربر جدید
    کسی نیست جواب بده؟
  5. #5
    تاریخ عضویت
    2014/09/29
    محل سکونت
    IoT Devices
    نوشته ها
    2,971
    امتیازها
    159,550
    سطح
    100
    9,328
    متخصص شبکه و الکترونیک
    نقل قول نوشته اصلی توسط mammad24amin نمایش پست ها
    کسی نیست جواب بده؟
    شما wsl را روی خود ویندوز نصب کن. روی hyperv درست جواب نمیده.

  6. #6
    تاریخ عضویت
    2021/01/30
    نوشته ها
    27
    امتیازها
    188
    سطح
    3
    3
    کاربر جدید
    نقل قول نوشته اصلی توسط ErfanDL نمایش پست ها
    شما wsl را روی خود ویندوز نصب کن. روی hyperv درست جواب نمیده.
    داداش گلم من wsl رو روی خود ویندوز نصب کردم ولی wsl 2 نیازمندیش hyper v هست! الان مجازی سازی رو سیستمم فعاله از دو برنامه چک کردم ولی wsl 2 باید حتما یه دستوری بزنی براش که اینه
    dism.exe /online /enable-feature /featurename:VirtualMachinePlatform /all /norestart
    اگه اینو بزنی یه سری قابلیت فعال میشه که ld player از کار میوفته! الان این feature فعال نیست wsl اجرا میکنم:
    Please enable the Virtual Machine Platform Windows feature and ensure virtualization is enabled in the BIOS.
    For information please v***t https://aka.ms/wsl2-install
    یعنی میگه اول مجازی سازی بایوس فعال کن و بعد قابلیت (feature) Virtual Machine Platform Windows رو فعال کن. مشکل من همینه!
  7. #7
    تاریخ عضویت
    2014/09/29
    محل سکونت
    IoT Devices
    نوشته ها
    2,971
    امتیازها
    159,550
    سطح
    100
    9,328
    متخصص شبکه و الکترونیک
    نقل قول نوشته اصلی توسط mammad24amin نمایش پست ها
    داداش گلم من wsl رو روی خود ویندوز نصب کردم ولی wsl 2 نیازمندیش hyper v هست! الان مجازی سازی رو سیستمم فعاله از دو برنامه چک کردم ولی wsl 2 باید حتما یه دستوری بزنی براش که اینه

    اگه اینو بزنی یه سری قابلیت فعال میشه که ld player از کار میوفته! الان این feature فعال نیست wsl اجرا میکنم:
    Please enable the Virtual Machine Platform Windows feature and ensure virtualization is enabled in the BIOS.
    For information please v***t https://aka.ms/wsl2-install
    یعنی میگه اول مجازی سازی بایوس فعال کن و بعد قابلیت (feature) Virtual Machine Platform Windows رو فعال کن. مشکل من همینه!
    خب مجازی سازی رو فعال کردین از تو بایوس ؟ مدل مادربورد و پردازنده چیه ؟

  8. #8
    تاریخ عضویت
    2021/01/30
    نوشته ها
    27
    امتیازها
    188
    سطح
    3
    3
    کاربر جدید
    نقل قول نوشته اصلی توسط ErfanDL نمایش پست ها
    خب مجازی سازی رو فعال کردین از تو بایوس ؟ مدل مادربورد و پردازنده چیه ؟
    آره فعاله مدرک:

    برای دیدن سایز بزرگ روی عکس کلیک کنید

نام: Untitled.png
مشاهده: 2
حجم: 29.3 کیلو بایت
    و اینم بگم تنها زمانی که اون دستور مخصوص wsl 2 که
    dism.exe /online /enable-feature /featurename:VirtualMachinePlatform /all /norestart
    مرو اجرا میکنم میگه غیرفعال شده! مادربورد هم اینجوری
    MSI A75A-G35 (MS-7695) (P0)
    سی پی یو هم:
    AMD A6-3500
  9. #9
    تاریخ عضویت
    2014/09/29
    محل سکونت
    IoT Devices
    نوشته ها
    2,971
    امتیازها
    159,550
    سطح
    100
    9,328
    متخصص شبکه و الکترونیک
    نقل قول نوشته اصلی توسط mammad24amin نمایش پست ها
    آره فعاله مدرک:

    برای دیدن سایز بزرگ روی عکس کلیک کنید

نام: Untitled.png
مشاهده: 2
حجم: 29.3 کیلو بایت
    و اینم بگم تنها زمانی که اون دستور مخصوص wsl 2 که
    dism.exe /online /enable-feature /featurename:VirtualMachinePlatform /all /norestart
    مرو اجرا میکنم میگه غیرفعال شده! مادربورد هم اینجوری
    MSI A75A-G35 (MS-7695) (P0)
    سی پی یو هم:
    AMD A6-3500
    گزینه Virtual Machine Platform را از windows features فعال کنید.

    برای دیدن سایز بزرگ روی عکس کلیک کنید

نام: 11.PNG
مشاهده: 3
حجم: 16.9 کیلو بایت

  10. #10
    تاریخ عضویت
    2021/01/30
    نوشته ها
    27
    امتیازها
    188
    سطح
    3
    3
    کاربر جدید
    نقل قول نوشته اصلی توسط ErfanDL نمایش پست ها
    گزینه Virtual Machine Platform را از windows features فعال کنید.

    برای دیدن سایز بزرگ روی عکس کلیک کنید

نام: 11.PNG
مشاهده: 3
حجم: 16.9 کیلو بایت
    خب داداش میدونم مشکل همینه! وقتی اینو فعال میکنم ld player باز نمیشه!
صفحه 1 از 2 12 آخرین
نمایش نتایج: از 1 به 10 از 11

اطلاعات موضوع

کاربرانی که در حال مشاهده این موضوع هستند

در حال حاضر 1 کاربر در حال مشاهده این موضوع است. (0 کاربران و 1 مهمان ها)

کلمات کلیدی این موضوع

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •